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Introduction
Welcome to the YAWC Pro User Guide. This guide shows you how to create high-quality web pages
directly from MS-Word 97, 2000 or XP, without any knowledge of HTML, the markup language used for
web pages. Publishing web pages using YAWC Pro improves on the standard Word function to save a
document in HTML format in a number of ways.

● YAWC Pro adds top and side navigation bars, and other style information, to your
documents as it converts it, so that the resulting web pages automatically conform to
the look and feel of the website on which they will be published.

● YAWC Pro can automatically upload the web pages it generates directly to the
correct destination on your website, so that you can publish content directly, in a
single step, rather than tediously having to navigate to the right location on the local
file system and remote web server with a separate FTP client application.

● YAWC Pro generates high-quality HTML markup, which is suitable for reading by
people with disabilities of all kinds, so your web pages are equally accessible to users
of all abilities.

● YAWC Pro allows you to maintain metadata in your Word document which will
make it easier for users to search your website and find the information they require.

Getting Started

System requirements
To install and run YAWC Pro, you must have the following software installed on your PC.

● Microsoft Windows 95, 98, ME, NT 4.0, 2000, or XP

● Microsoft Word 97, 2000, or XP

● Microsoft Internet Explorer 5.0 or higher

YAWC Pro has been tested mainly on English language editions of Word and Windows. However, it has
been successfully installed and run on the following other European languages.

● German

● Italian

Installing and testing YAWC Pro
To install YAWC Pro, download and run the YAWC Pro setup program, which is available at
http://www.yawcpro.com/download/. We recommend that before purchasing YAWC Pro, you download
and install the evaluation version, to ensure that it works correctly on your PC.

The setup program automatically installs all the software you need to run YAWC Pro. When installation is
complete, you are prompted to view the Getting Started Guide before you exit Setup. We recommend that
you do this each time you install YAWC Pro on a new PC, to ensure that it has been properly installed.

The remainder of this guide assumes that you have successfully installed and tested YAWC Pro on your
Windows PC.



Creating a new web page
This section describes how to create a new web page from scratch, using the YAWC Web Page template and
MS-Word.

Step 1. In the File menu, select 'New…' and choose the YAWC Web Page template. This will open a new
blank document, with a single word "Title".

Step 2. Save the new document to the location you require. We recommend that you keep all web pages
together in the same directory, and choose file names that describe clearly the content of the document.

Step 3. Replace the text "Title" with the title of the document you wish to write. Try to keep the title length
short enough to fit on a single line.

Step 4. Write the rest of your document in the paragraphs following the title.

Web pages normally consist of the following components.

● Text (Headings, lists and paragraphs of text)

● Tables

● Graphics

● Hyperlinks

● Metadata

The following sections provide more information on how to write these document components in such a
way that they appear properly as web page content. The basic principle to remember is that MS-Word has
predefined styles for each of these components; by using them, you can create a high-quality web page. If
you do not use them, the quality and appearance of the web page will not be as you expect. To view styles
as you type, select YAWC>Utilities>Show/hide style area. This will display paragraph styles in a
resizable window on the left side of your MS-Word window area.

Text
It is important for readability reasons that you define a clear hierarchical structure for each web page.
Structure is defined using headings of various levels. Many short web pages may contain no headings other
than the title, but longer documents may use many heading levels to break the information in the document
up into manageable chunks.

Applying Heading styles
There are a variety of ways of applying heading styles in a document. The YAWC menu and toolbar enable
you to apply heading styles using shortcut keys or single mouse-clicks. Use the following keyboard
shortcuts to apply heading styles.

Press For this style
Ctrl-T Title

Ctrl-1 Heading 1

Ctrl-2 Heading 2

Ctrl-3 Heading 3

Ctrl-4 Heading 4



Alternatively, on the YAWC toolbar, click on the letter T, or any of the numbers 1 to 6, to convert the
current paragraph to a title or heading. In the YAWC menu, choose 'Heading Styles…' and the title or
heading level you require. Finally, you can also use ALT-SHIFT-RIGHTARROW to apply a heading level
one lower than the last applied heading.

Do not use bold or font size to create a heading! Although this might look OK, the resulting web page is
much more difficult to read for people with disabilities, and YAWC is designed to create pages equally
accessible to everyone.

Applying List styles
The YAWC menu and toolbar enable you to apply list styles using shortcut keys or single mouse-clicks.
Use the following keyboard shortcuts to apply list styles.

Press For this style
Ctrl+9 List Number

Ctrl+Shft+( List Number 2

Ctrl+8 List Bullet

Ctrl+Shft+* List Bullet 2

Ctrl+7 List

Ctrl+Shft+& List 2

Alternatively, on the YAWC toolbar, click on the bullet or numbered list icons to convert the current
paragraph to a list. In the YAWC menu, choose 'List Styles…' and the list style you require.

Do not use the bullet or numbered list icons in the format toolbar to create a list! Although this might look
OK, the resulting web page is much more difficult to read for people with disabilities, and YAWC is
designed to create pages equally accessible to everyone.

Choosing an appropriate list style
Use a bullet list (List Bullet style) to itemise a series of points where order is not particularly important, for
example, a list of alternative colours.

Use a numbered list (List Number style) to itemise a sequence of items have a particular order, for example,
a list of steps in a procedure.

Use a list continuation style (List Continue style) to add a second paragraph of text to a list item, without
generating a second bullet or number icon.

Use the List style if you want to create a list with your own numbering sequence. This is often required for
complex legal documents, which have quite idiosyncratic paragraph numbering conventions. The list style
provides only indentation in this case, and does not add a bullet symbol or number to each paragraph.

To create nested lists, multiple levels of list style are available, for example List Number 2, List Number 3,
List Number 4, etc. Each list level provides a larger indent, so it is easy to distinguish items from different
levels.

Example of a List:
1. This line uses the List Number paragraph style.

2. This uses the List Number paragraph style.

This is a continuation paragraph. It is styled as List Continue.



a. This is the start of the nested numbered list. It is styled as List Number 2.

b. This is the second item in the nested numbered list. It is styled as List Number 2.
This is continuity paragraph preceded by a soft return. It is styled as List Number 2.

3. This is a continuation of the original numbered list. Note that the number does not continue in the
correct sequence. It should be numbered 3. This is a limitation of Word and can be ignored. It will
convert to a 3 in the XML. If preferred, you can manually override the number but this is not
necessary, as it will be correctly numbered in XML.

● This is the start of a nested bulleted list. It is styled as List Bullet 2.

● This is the second item in the nested bulleted list. It is styled as List Bullet 2.
This is continuity paragraph preceded by a soft return. It is styled as List Bullet 2.

4. Returning to the original numbered list again. This line should be numbered 4. It is styled as List
Number.

Note: In some cases, MS-Word may not number nested numbered lists
correctly. List items may begin again at 1. This can be solved in a number of
ways. 1. Select the problem list item, choose Format>Bullets and
Numbering>Modify, and change the Start At value to the required
number. 2. Select all list items, format them with the List Number style, and
then re-format each lower-level nested list with the appropriate style. The
number on the top level list should retain the correct sequence.

Character styles
Character styles are not part of document structure, but are used to apply a particular presentation, usually
bold or italic to a word or phrase in a paragraph. Applying a character style is easy, getting rid of it
sometimes not. To remoce a character-level style, select the entire text that is styled incorrectly, and press
Ctrl+Space (Control key and space bar).

Press For this style
Ctrl+B Bold

Ctrl+I Italic

Ctrl+SPACE Default paragraph font

Ctrl+K Hyperlink

Quote

Tables
Any tables you create in MS-Word will be converted into similar tables in your web page. Most word table
presentation features are not possible to re-create in HTML, so only simple table presentations are possible.
When creating tables, we recommend that you always supply a title before the table, using the Table Title
style. This is to improve the readability of the page for people with disabilities.

Graphics
MS-Word supports many different image formats, but when publishing information on the web, only 3
formats are generally used: GIF, JPEG, and PNG. JPEG format is suitable for photographs, and GIF format



for most other types of graphic. When inserting images into Word, you must link the image rather than
embedding it, as YAWC Pro does not support embedded images.

Use the following steps to link an image into your Word document.

Step 1: Copy your images as GIFs or JPEGS to the same folder as your Word document or in a folder
directly below it e.g. images/fig01-01.gif.

Step 2: Place the cursor on the paragraph of your document where you want to insert the image.

Step 3: Choose Insert>Picture>From File...

Step 4: In Word 97, select the image you want to insert, select the Link to file option, clear the Float over
text and Save with document options and click OK.

In Word 2000, select the image you want to insert, click on the down-arrow to the right of the Insert
button, and click on the Link to file button.

Step 5: Ensure that the link to the image is correct. Choose Edit>Links.... The links are likely to have
relative path names.

Step 6: Select the Change Source... button and select the images again. Select the Update button. This
ensures that the reference to the image location will be correct in the web page. Note the link for the
image named "link1.gif" has been changed:

Tip: To quickly change a number of absolute paths to linked images; turn on
Field Codes and use Edit/Replace to replace the common absolute path
with nothing.

Hyperlinks
Hyperlinks are the phrases of blue underlined text on web pages that allow you to browse between pages.
The location or address of a web page is called a URL, and has the form
http://www.yawcpro.com/about.html. You can create hyperlinks in MS-Word in a number of ways. There
are different types of hyperlink, so the most convenient method to use depends on the type of hyperlink.

External hyperlinks
An external hyperlink is one which points to a page on another website rather than your own. To create an
external hyperlink, simply type in the complete URL or address. MS-Word will automatically convert the
URL to the predefined character style Hyperlink. If you wish to replace the actual URL with a more
understandable name, press Ctrl+K to edit the hyperlink and replace the Text to display field with the
name.

Internal hyperlinks
Internal hyperlinks are links to another part of the same document, and are directly analogous to bookmarks
in MS-Word. To insert an internal hyperlink to a heading, press Ctrl+K, select Place in this document, and
navigate the displayed document structure to select the heading you require.

Relative hyperlinks
Relative hyperlinks are links to another web page or document on the same website as the current
document. Use the following steps to create a relative hyperlink.

1. Press Ctrl+K to open the Insert Hyperlink dialog box.

2. Click the File… button, and navigate to the directory containing the file you wish to link to. Select the
file by clicking on it once.



3. In Word 97, check the Use relative paths for hyperlinks box.

4. Click OK to return to the Insert Hyperlink dialog box, fill in the Text to display field, and click OK.

In Word 2000, you must manually make the hyperlink relative, as there is no checkbox for requesting a
relative path.

1. Show field codes by clicking the '{a}' icon in the YAWC toolbar. This will display the URL behind the
hyperlink.

2. Edit the URL to remove the absolute path, leaving only the relative path you require. You should use
two backslashes (\\) to represent each forward slash (/) you require.

3. Right-click over the link to display the context menu, and select the Update Field item.

Metadata
Metadata is information about your document. This information helps search engines on the web to index
your information better, making it easier for people to find the right information. YAWC provides support
for Dublin Core Metadata, which is the de facto standard for the web. Select YAWC>Edit Metadata… to
view the metadata dialog box. This box is divided into 3 tabs, one for required metadata (Mandatory), one
for desirable metadata (Recommended), and one for other metadata which may be needed only for certain
types of pages. This categorisation follows the Irish Public Service Metadata Standard (IPSMS).

Some metadata is predefined and constant for a particular website, for example, the name of the publisher,
the language, the format, and a rights notice. Other metadata is specific to a page, such as the Identifier,
which should normally be the location (URL) of the page on its website, including the website address.

Mandatory metadata field names and descriptions

Metadata field
name

Description Default

Title The title of this page, as entered on the Title style at the top of
the document

{titleFromDocument}

Creator The subdivision of an organisation (e.g. Accounts Dept.) or
the name of the person who created or is responsible for this
page.

None

Subject Keywords describing this document None

Publisher The name of the organisation responsible for publishing this
document

Set in configuration
file

Date created {createdDate}

Date modified {modifiedDate}

Identifier

Type None

Recommended metadata field names and descriptions

Metadata
field name

Description

Contributor

Format



Source

Language

Relation

Coverage

Rights

Other metadata field names and descriptions

Metadata
field name

Description

Description

Keywords

Metadata field values can be set in a number of locations:

1. YAWC Configuration file (yawcHTML.ini)

2. Word template (HTML-en.dot)

3. Predefined keywords

4. Manually

Converting your document into a web page
Once you have written your document, you should save it in an appropriate location, wherever other
documents published on your website are maintained. To convert your document into a web page should be
as simple as selecting YAWC>Export…, but for this to work, YAWC Pro must be set up and configured
for your particular website. The steps required to do this are described in the YAWC Webmasters Guide. By
default, YAWC is configured to convert your document into HTML, and leave it in the same directory as
your Word file. YAWC can also be configured to automatically copy the HTML directly to its correct
location on your organisations website.

To convert your document, first check that it is correctly structured, by selecting YAWC>Verify… (or
pressing Ctrl+6). This verification process carries out a number of simple checks on your document, to
ensure that is marked up correctly, and will convert properly. The following are the checks currently
carried out.

● The document begins with a Title style;

● Headings are properly nested.

● Lists are properly nested.

● Images are linked, not embedded.

● Hyperlinks are correctly entered.

A list of any errors found is displayed, along with a short description. Click on the description to highlight
the area in the document where the error was found. All errors must be fixed before the document can be
converted.



Select YAWC>Export… (or press Ctrl+5) to convert your document into a web page. A dialog box is
displayed describing each step in the process. When complete, the web page will be saved in the same
directory with the same name as the Word document, but the suffix .htm instead of .doc. You can check the
web page by opening it in your web browser.

If your installation has been configured to do so, the web page will also be automatically copied to its its
designated location on your organisations website.

The YAWC Menu
The following commands are available from the YAWC menu and toolbar.

● Export - Convert the current document into a web page or other XML format.

● Verify - Verify that the document is correctly marked up.

● Edit Metadata – View and edit Dublin Core metadata fields for the document.

● Heading styles – Apply a heading level or title style to the current paragraph.

● List styles – Apply a list style to the current paragraph.

● Other styles – Reset the current paragraph or phrase to the default style.

● Utilities – Carry out one of a number of miscellaneous commands.

● Options – Set YAWC parameters.

● Register – Set or view the license key details for YAWC Pro.

● About – Information about the current version of YAWC.

Error Messages

Cannot run macros
If you receive the following error message, it is because your macro security level is set to HIGH, which is
preventing the XML macro from running. To resolve this, choose Tools-Macro-Security and change the
Security Level to Low.

Export fails
The Export process can fail if the document is not properly structured, or the configuration is not correct.
Click More in the Export dialog box to see more details of where the process failed. Some possible actions
to resolve this are the following.

● Run verify if you have not already done so, and correct any highlighted errors.

● If the export still fails, exit MS-Word completely and start it again.

● Save the Word document in RTF format, open it again, and save it back in MS-Word



Document format.


